POS Service and Store Service delayed

Incident Report for Fiftytwo

Resolved

This incident has been resolved. All systems operational
Posted Aug 04, 2026 - 16:07 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 04, 2026 - 15:53 CEST

Update

The issue has been identified and a fix is underway shortly
Posted Aug 04, 2026 - 15:00 CEST

Identified

We have identified an issue with the POS and Store Service causing creation requests to be heavily delayed. We apologize for any inconvenience
Posted Aug 04, 2026 - 08:47 CEST
This incident affected: POS Services and Store Services.